Bill Williams (IT): Support Site
Bill Williams (IT): Support Site

adv25_341.gif
[home] | [profile] | [register] | [help] | [Contact Us]

[Sections]
[Script Writers Toolkit]
       this page
Script Writers Toolkit   [Append to Topic]
[Tell someone about this]
By Macros and Buttons.
Ken Edit MessageUploaded - 3 Dec 2012 02:31

A few years ago, I bought from you the Data Highways toolkit, and wrote several things which have not yet been produced. I'm trying to use it again now, in Word 2007 under Windows XP, and have found that only some of the macros work, despite have been prompted to enable them, and having done so, apparently succesfully. I say that because no error message was generated.

I find now that when - for instance - I hit CTRL+SHIFT+M, I get what should appear as a result of CTRL+SHIFT+Z. Can you explain, please, and if not, can you tell me how I can upgrade?

Best wishes

Ken

Bill Williams


Edit MessageUploaded - 3 Dec 2012 02:32

The installation process ensures that the toolkit works properly & reliably each time, by omitting the proper installation before, you may have got in a muddle.

Anyway, for macros and things to work properly, Microsoft word requires that there is a copy of the TEMPLATE itself on the hard disk (not just the script which is a DOCUMENT based on the template) and that the document 'knows' where the template is located. i.e the relevant template is "attached" to the document.

I will be producing video tutorial for installing and running on Vista/Win7 and Office2007/2010 but these take a long time to get right. I just did some recording for them, but it will probably be days before I do anything with those rough recordings.

Meanwhile see if the following procedures will get you going.

First ensure that you create a copy of the templates on your C: drive in folder script5 within a new folder called "Templates". The procedure for XP is shown in the first portion of this video
http://www.youtube.com/watch?v=RYWhN17oq4g
and it is fairly similar under Vista or Win7 so you should be able to do that bit on any system.

Next you need to attach your script to the template.
1.Open your Script in Word 2007, then
2.click the Office Button (which is the big round button at top left of Word 2007).
3. Click "Word Options" on the bottom line of the dialog box that has opened.
4. Click Add-ins in the left column of the Word Options Dialog box
5.Drop down the "Manage" list and choose Templates
6. Click Go
7. Click the Attach Button
8. Navigate to Computer then your C: drive then C:\templates
9. Double click Scripts5 folder to open it
10. Within Scripts5 choose the template that you used before for your script, highlight it
11. Click the Open button
12. Click the OK button of the "Templates and Addins" dialog box
13. You should now be back viewing your script in the main window of Word 2007
14. The Option "Add-ins" will now have appeared on the Menu line (2nd line from the top of the Word 2007 window).
15 Click on that Add-ins tab and the ribbon will change to show the Scriptwriters Toolkit menu options, including the Smiley face icon that you couldn't find before.

Test the keystroke macro difficulties that you reported in your first email and tell me whether or not they now work as designed.

Regards
Bill Williams

PRHEdit MessageUploaded - 3 Dec 2012 02:34

I installed the templates as per your video on YouTube, and everything is working fine with one exception. The Add-In toolbar does not show up for me. I can see the macros in the document by going to Macros, but I don’t get the icons to launch them, so I’m not sure for some of the macros which ones I am supposed to use. I’m using Word 2007 on Windows XP.

Thanks
PRH
Bill Williams


Edit MessageUploaded - 3 Dec 2012 02:35

Almost all of the actions are normally done from the keyboard combination strokes, the icons in the add-ins menu are just extras, not essential. Do your keystrokes work?

If not, at this stage I can only guess that you are using it in a large 'corporation' office and your system administrators have locked all copies of MS Word so that they can't execute untrusted macros. You would need to talk to your local support staff to fix that.

If the keystrokes are working and the initial macros operate at start up, the only macros you are likely to need to invoke by name are the ones to "Make Submission Script" or similar. The rest have keystrokes, listed on the crib page.

Let me know how you get on.
Regards
Bill Williams

PRHEdit MessageUploaded - 3 Dec 2012 02:36

I am on a corporation machine, but keystrokes work fine. Is there a keystroke to open the dialog to add character names? Everything out is fine with the templates.

Thanks, and wonderful product!

Bill Williams


Edit MessageUploaded - 3 Dec 2012 02:37

Ah, no. There isn't a key defined for the Cast Table, but I think you can choose to define a keystroke yourself.

In Word 2003 it is in Tools -> customise, but I'm not sure where it is in Word 2007. Find out by opening help and searching for "assign key".

The relevant macro in the Hollywood template is "ShowCast" or "people20" ; you did not specify which templates you actually use. Hmmm Word 2003 does not let me assign a keystroke to a protected macro. If Word 2007 also has this restriction, you can work around it by recording your own local macro called say CAST, which merely consists of you opening the list of macros from Tools and then doing a RUN on ShowCast. Then stop recording the macro. Then you will be able to assign a keystroke combination to your own macro: CAST

Its very puzzling why your Word does not show the addons toolbar, check the various tools options to see if it is turned off somewhere. Is it perhaps on a tab hidden behind another toolbar or is it pushed off the right side of the screen. Try running the macro called SetToolbar, this switches off the unwanted toolbars just leaving the toolkit's toolbar.

Let me know how you get on
Regards
Bill Williams

PRHEdit MessageUploaded - 3 Dec 2012 02:37

SetToolbar took care of it for me – thanks! That made the toolbar display. Again, wonderful product – this is very helpful to me! I am using the Stage5a template right now, by the way.

Bill Williams


Edit MessageUploaded - 3 Dec 2012 02:38

Ok, I am glad you like it.

The fact that SetToolbar worked, indicates that you should be able to turn the toolbars on and off as needed, from the normal Microsoft Word facilities. Check its help file if necessary, to find out how to do that.

Have fun

Regards
Bill Williams

KLEdit MessageUploaded - 3 Dec 2012 02:42

My apologies for emailing you directly but I couldn’t find answer to the queries below on your support forums and I couldn’t register on the site either in order to post my queries there (I’ve let the webmaster know). My queries are that I’m encountering some glitches in two of the templates within my Word 2010 installation of your toolkit – for which, thanks very much! – it looks great.

I’m specially trying out the “Stage 5a”, “Stage 5b” and Stage 5c” templates using File / New where I encountered the following after successfully creating the documents via your initial macros:

· Stage 5a and stage 5b: There is no button on menu commands group of the add-ins ribbon for creation of a production of submission script. (There is such a button in Stage 5c called “make Production Script). Do you think this is a glitch in the master template or in my installation of it? And how might I fix it perhaps?

o I couldn’t find an icon in the Custom Toolbars group to achieve the same action either. (Maybe there isn’t supposed to be one)

· Stage 5a and Stage 5b: None of the buttons in the Menu Commands group of the Add-Ins ribbon will run anything. I get a message about saying either my macros are missing or I’m encountering macro security problems even though the macros for some of these ran when I created the document. But equivalent buttons DO work in Stage 5c, and the macros in 5a and 5b do run when I invoke them manually, or via icons in the Custom Toolbars group, suggesting that macro security isn’t the problem and neither is macro existence. So I wondered if these buttons had somehow become detached from their macros. Is it obvious to you what’s going wrong here, and how I might fix it perhaps?

· Stage 5b: Because there is no button to make a submission/production script, I tried running the RemoveTheMagic macro. This produced the expected black and white, newly named …x_production.doc file but the instructions were still at the front. If I ran the equivalent macro manually in Stage 5a or Stage 5c, then the instructions WERE removed correctly. Do you know how I might fix the macro’s behavior in Stage 5b perhaps?

Because I can’t edit the macros I don’t have any other insights into whether the macros are misbehaving, but I did try to some of the above tests, especially of Stage 5b, on two other PCs, again installing them as templates and invoking them via File / New, and both exhibited the same problems. And I tried a random sampling of some of the other scripts and they worked fine.

So might you know how I would fix the above glitches in Stage 5a and especially Stage 5b perhaps?

Thanks very much for your help. I’m not actually trying to use the templates myself – my 78-year old mother is as part of an exercise on an Open University course where she has to produce a script but is given no guidance on how to do so in Word. So your templates look like an absolute boon for her. I can sometimes tidy up the scripts for Production if need be, but it’d be great if she could use your facilities fully to do so because I’m sometimes away for business and unavailable as she nears course deadlines. And, in any case, if it turned out that the macros or buttons were misbehaving, then I thought you’d want to know.

Thanks for any solution pointers you might have.

KL

Bill Williams


Edit MessageUploaded - 3 Dec 2012 02:43

Its very puzzling why your Word does not show the addons toolbar sometimes, check the various tools options to see if it is turned off somewhere. Is it perhaps on a tab hidden behind another toolbar or is it pushed off the right side of the screen. Try running the macro called SetToolbar, this switches off the unwanted toolbars just leaving the toolkit's toolbar.

Let me know how you get on
Regards
Bill Williams

I will need to look into the other matters you mention separately.

Revised by - Bill Williams on 3 Dec 2012 at 02:46:28

Revised by - Bill Williams on 3 Dec 2012 at 02:48:38

Bill Williams


Edit MessageUploaded - 4 Dec 2012 13:50

Oh, how very odd... On investigation I find that those facilities are not present in stage5a and stage5b templates even when using Word2003 and you are the first person to notice. Somehow I must have included incomplete copies of those two templates in the package way back in 2003, nine years ago.

It will take me a while to find the correct editions or to re-create them and I will update the downloadable copy of the toolkit when they are ready. I will make their behaviour as close as possible to stage5c, which does seem to be working correctly.

Thank you for finding the problem.


Bill.

Home Page.

Click to Add Comments.

Click Here To Close Topic, Administrators & Moderators Only.

	
	
	
	
	
	
	

Implemented by Bill Williams (IT)
based on ASP Forum.

1622
adv25_341.gif